Platform Degraded Performance.
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Nov 04, 2024 - 19:15 CET
Monitoring
We are currently investigating a possible issue causing slow load times on our platform.
Posted Nov 04, 2024 - 18:51 CET
This incident affected: Platform (Platform Apps).