Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Whatsapp for Business - Degraded performance for a few customers
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted May 17, 2021 - 23:19 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2021 - 20:05 CEST
Investigating
We are experiencing degraded performance on our Whatsapp For Business platform which might affect a few of our customers. The majority of our customer will not experience any degraded performance. We are investigating the issue.
Posted May 17, 2021 - 19:38 CEST
This incident affected: Mobile Service Cloud (WhatsApp).