Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Degraded performance Checkout
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 20:52 CEST
Identified
We are currently investigating this issue and working on a solution.
Posted Jun 03, 2021 - 16:46 CEST
This incident affected: Pay (Checkout).