Electronic Cash Register - Zettle Payments
Incident Report for CM.com
Resolved
The incident has been resolved and payments using Zettle are available again.
Posted Jul 17, 2024 - 12:09 CEST
Investigating
We are currently investigating an issue where customers are unable to pay using Zettle.
Posted Jul 17, 2024 - 11:51 CEST
This incident affected: Electronic Cash Register (Electronic Cash Register).