Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Customer contact - degraded performance
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted May 25, 2021 - 16:20 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2021 - 15:08 CEST
Investigating
We are experiencing degraded performance on the Customer Contact platform. We are investigating the issue.
Posted May 25, 2021 - 14:38 CEST
This incident affected: Mobile Service Cloud (Customer Contact).