Degraded Platform Performance
Incident Report for CM.com
Resolved
The degraded performance has been resolved.
Posted Jul 08, 2020 - 22:12 CEST
Monitoring
Due to heavy loads you may experience a degraded system performance. We are monitoring the system closely.
Posted Jul 08, 2020 - 21:05 CEST
This incident affected: Platform (Address Book).