Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
WhatsApp for Business - Degraded performance
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted May 12, 2022 - 13:07 CEST
Update
We are continuing to monitor for any further issues.
Posted May 12, 2022 - 12:47 CEST
Update
We've found the cause and resolved the issue that was causing the delay.

We're currently monitoring the impact of this.
Posted May 12, 2022 - 12:24 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 12:24 CEST
Investigating
Degraded performance on our WhatsApp for Business is still ongoing for a few of our customers. We are working on a solution and will update you soon.
Posted May 12, 2022 - 12:15 CEST
This incident affected: Mobile Service Cloud (WhatsApp).