Planned maintenance - core network
Scheduled for Oct 16, 23:00 CEST  -  Oct 17, 00:00 CEST
Update
This maintenance has been postponed. The new date is Monday October 16th.
Posted Sep 29, 2023 - 13:37 CEST
Scheduled
On Monday, October 2, 2023, at 23:00 UTC+2, we will be performing routine maintenance on our core network. All our services will remain fully operational during this maintenance window.
Posted Sep 15, 2023 - 15:05 CEST