Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Operator Service Interruption - Belgium - Telenet - 20605
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 06:09 CET
Investigating
Belgium Operator Telenet (20605) is experiencing an issue on their platform which affects MT/MO SMS traffic and Status Reports. The operator is investigating the issue.
Posted Mar 23, 2021 - 04:50 CET
This incident affected: External Services (Mobile network operators: Belgium).