Operator Service Interruption - Telefonica O2 Germany (26207)

Incident Report for CM.com

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 22:10 CET

Investigating

We are currently investigating this issue.
Posted Mar 06, 2026 - 09:35 CET
This incident affected: External Services (Mobile network operators: Germany).