Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
iDEAL service interruption - Rabobank
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Sep 04, 2021 - 11:36 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 04, 2021 - 11:14 CEST
Identified
Rabobank is having issues with iDeal transactions we are awaiting for updates.
Posted Sep 04, 2021 - 11:13 CEST
This incident affected: External Services (Payment method: iDEAL).