Operator Traffic Delay - Belgium
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 11:34 CEST
Identified
We are currently experiencing delays due to congestion towards BE-Orange-20610 affecting MT traffic.
Delayed delivery towards this destination may be experienced.
Posted Jul 01, 2022 - 11:06 CEST