Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Issue creating Campaigns - Resolved
Incident Report for CM.com
Postmortem

As an unintended side effect of a recent application update it was not possible to create new mobile or email campaigns, or import new Address book contacts in certain situations. The update has been rolled back and improvements pertaining to this issue are implemented. We apologies for any inconvenience caused.

Posted Mar 03, 2021 - 12:29 CET

Resolved
Our engineers have solved an issue which was was causing problems when creating new campaigns in both the Campaign and Email Campaigns Apps.
Posted Mar 03, 2021 - 07:41 CET