Platform - Invoice download is not possible
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 16:29 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 15:13 CET
Identified
At this moment, it is not possible to download invoices in our invoice web application. We are working on the solution and expect to resolve this issue later today.
Posted Mar 18, 2024 - 13:17 CET
This incident affected: Platform (Platform Apps).