Agent Inbox: slow responses

Incident Report for CM.com

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 17:00 CEST

Monitoring

We've found the issue that was blocking the processing of tasks and we are processing normally again for new traffic. This was also attributable to the failed release. Now that we've tackled the root cause, we're scaling out our infra to expedite the speed with which we can catch up on backlogged tasks.
Posted Apr 22, 2026 - 13:47 CEST

Identified

We identified a release that contained an index update which inadvertently failed mid process causing database hick-ups. 
This issue has been resolved, the performance (speed/loading of conversations) of the app is back to normal.
Our engineers are still working on restoring normal queue processing.
In/Outgoing traffic may still be delayed.
Posted Apr 22, 2026 - 11:47 CEST

Update

We are continuing to investigate this issue.
Posted Apr 22, 2026 - 10:54 CEST

Investigating

We have noticed issues regarding slow loading/not loading of the Agent Inbox. We are currently investigating this issue.
Posted Apr 22, 2026 - 09:46 CEST
This incident affected: Mobile Service Cloud (Agent Inbox).