Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Paymentservice Disturbance
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 07:58 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2021 - 07:51 CEST
Update
We are continuing to investigate this issue.
Posted Jun 09, 2021 - 06:48 CEST
Investigating
We are currently investigating this issue.
Posted Jun 09, 2021 - 06:47 CEST
This incident affected: Pay (Payment Service Provider API).