Investigating DLR delays

Incident Report for CM.com

Resolved

This incident has been resolved.
Posted Oct 31, 2019 - 18:33 CET

Investigating

We are currently experiencing delays in the return of Delivery Receipts (DLR) to our customers.

Only Delivery Receipts are affected. MT and MO traffic delivery itself is NOT affected.
Posted Oct 31, 2019 - 17:21 CET