External service: Payment method iDEAL unavailable for ING users
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 16:29 CEST
Investigating
ING is having problems with their connectivity towards Ideal platform. This is causing downtime for ING clients using iDEAL.

Status iDEAL is availble here: availability.ideal.nl
Posted Jun 02, 2023 - 15:30 CEST
This incident affected: External Services (Payment method: iDEAL).