Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Operator degraded performance - BE - Base - 20620
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 13:11 CET
Identified
BE - Base - 20620 is experiencing an issue on their platform which affects MT SMS traffic and Status Reports.
All MT messages are currently being delivered with a delay.
The operator is investigating the issue.
Posted Mar 23, 2021 - 10:21 CET