We continuously monitor the status of our platform as well as external services we are using. If there
are any interruptions in service, a note will be posted here.
For more information or any questions, please contact our Customer Service
Update 18:40 CEST – WhatsApp Business Messaging service is currently restored. We are continuing to monitor the situation.
Posted Jun 12, 2026 - 18:44 CEST
Update
Update 16:30 CEST - Meta has acknowledged the issue on their WhatsApp Business Platform. We will continue to monitor the situation and update this page once resolved.
Posted Jun 12, 2026 - 16:39 CEST
Update
We are continuing to investigate this issue.
Posted Jun 12, 2026 - 16:06 CEST
Investigating
Since 15:30 CEST, we are experiencing issues affecting WhatsApp Business.
We are monitoring the situation closely and will provide updates as more information becomes available. We apologize for any inconvenience.
Posted Jun 12, 2026 - 16:06 CEST
This incident affected: Messaging (WhatsApp Business).