We continuously monitor the status of our platform as well as external services we are using. If there
are any interruptions in service, a note will be posted here.
For more information or any questions, please contact our Customer Service
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 01, 2026 - 02:00 CEST
Scheduled
We wish to inform you that CM.com/IPP Payments datacenter provider is performing scheduled network maintenance.
Maintenance Window: 🗓 Date: Tuesday, 01 September 2026 ⏰ Time: 02:00 AM - 06:00 AM CEST (Central European Summer Time)
We do not expect any impact to payment processing. Our platform runs redundant connections across datacenters, and the work targets primary services one at a time.
Our technical team is available for the full window and will monitor the platform throughout. We will post an update here if anything changes.
Posted Aug 31, 2026 - 12:24 CEST
This scheduled maintenance affected: In Person Payments (Gateway, Merchant Portal, Processor Connections).