Ideal - External Payment Issues

Incident Report for CM.com

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 12:47 CET

Monitoring

According to the supplier this incident was resolved. Availability is back to normal.
Posted Nov 10, 2025 - 12:40 CET

Investigating

Some issuers are currently experiencing a problem due to a recent change implemented by Currence. This issue may affect iDEAL transactions for certain users. This issue is outside of our control and can only be resolved by Currence and the impacted issuers. We are actively monitoring the situation and will update this page as soon as more information is available. For the latest updates, please visit: https://availability.ideal.nl/
Posted Nov 10, 2025 - 12:39 CET
This incident affected: Online Payments (iDEAL QR) and External Services (Payment method: iDEAL).