Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Customer contact - degraded performance
Incident Report for CM.com
Resolved
Resolved
Posted Sep 14, 2021 - 12:04 CEST
Investigating
Customer Contact is reachable but experiencing some degraded performance. We are investigating
Posted Sep 14, 2021 - 09:03 CEST
This incident affected: Mobile Service Cloud (Customer Contact).