Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
General service interruption
Incident Report for CM.com
Resolved
Due to measures already in place we were able to avoid further disruptions
Posted Nov 17, 2021 - 15:31 CET
Investigating
We are currently experiencing a general disruption of our services. We are investigating and will update as soon as we know more.
Posted Nov 17, 2021 - 14:41 CET