We continuously monitor the status of our platform as well as external services we are using. If there
are any interruptions in service, a note will be posted here.
For more information or any questions, please contact our Customer Service
Issue has been identified, and a fix is implemented. New incoming in/outbound traffic is processed without delay, Product will continue monitoring the situation.
Posted Mar 18, 2026 - 15:16 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 18, 2026 - 15:13 CET
Monitoring
Issue has been identified, and a fix is implemented. Delayed in/outbound traffic is being processed at the moment. Product will continue monitoring the situation.
Posted Mar 18, 2026 - 15:13 CET
Update
Issue remains ongoing, product is investigating. All in/outbound traffic will be processed with a delay.
Posted Mar 18, 2026 - 14:38 CET
Investigating
There is a queue at Agent Inbox. this results in delayed processing of tasks.
This impacts the processing of all inbound and outbound work.
Product is investigating this issue at the moment.
Posted Mar 18, 2026 - 13:50 CET
This incident affected: Mobile Service Cloud (Agent Inbox).