Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
NL - KPN - 20408 Maintenance on March 23rd, 2021
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 01:23 CET
Identified
Dutch operator KPN will perform maintenance on the networks of 20408 and 20412 (Telfort). During the period MT, MO and SR may be impacted. 23-03-2021 00:00 - 01:00 CET
Posted Mar 23, 2021 - 00:14 CET
This incident affected: External Services (Mobile network operators: Netherlands).