Sign - delayed delivery of signed documents

Incident Report for CM.com

Resolved

The incident has been resolved. All queued documents have been successfully processed.
Posted Sep 23, 2025 - 08:49 CEST

Monitoring

We've implemented a workaround, the backlog of queued documents is being processed. We will keep monitoring the situation.
Posted Sep 23, 2025 - 07:36 CEST

Update

The outage at our certificate supplier is still ongoing. There's no immediate impact to the Sign service, as documents are queued to be signed later. We'll post another update once their service is restored.
Posted Sep 22, 2025 - 22:43 CEST

Identified

We are currently experiencing delays in the delivery of signed documents, due to our certificate supplier experiencing an outage. The Sign API and signing environments are fully available, but completed dossiers are queued. The signing of queued documents will automatically resume when the outage is resolved.
Posted Sep 22, 2025 - 20:40 CEST
This incident affected: Verification & Sign (Sign).