MO sms queuing
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 01, 2019 - 16:41 UTC
Investigating
MO messages are queuing at the moment. We are investigating the issue.
Posted 3 months ago. Jul 01, 2019 - 16:24 UTC