Current information on Service Availability

Subscribe to get real-time updates. Having trouble? Troubleshoot common issues in our Help Center.

Customer Service
Service interruption - KPN
Incident Report for CM.com
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 18:01 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2021 - 16:26 CET
Investigating
We are currently facing issues towards KPN network.
We are looking into this problem together with the operator.
Posted Feb 04, 2021 - 11:02 CET